Portal Locations table temporarily unavailable
Incident Report for Kollective Technology Inc.
Resolved
This incident has been resolved.
Posted May 10, 2023 - 20:48 PDT
Identified
Filtering on Locations table temporarily unavailable. A fix is in progress.
Posted May 10, 2023 - 09:49 PDT
This incident affected: Management Portal.